ubuntu18.04 nginx编译要用到的环境

build-essential 自动安装如下依赖

libc6-dev libc-dev libc6-dev gcc g++ make make-guile dpkg-dev

sudo apt install build-essential 
sudo apt install libtool 
sudo apt install openssl libssl-dev
sudo apt install libpcre3 
sudo apt install libpcre3-dev 
sudo apt install zlib1g zlib1g-dev

编译新增模块还用到了这些

sudo apt-get install libxml2 libxml2-dev
sudo apt-get install libxslt-dev
sudo apt-get install libgd-dev
点赞